Topic: Small improvement to n1613 (Design by Contract)


Author: tigrisek@interia.pl ("Robert Kawulak")
Date: Sat, 3 Jul 2004 01:21:54 +0000 (UTC)
Raw View
I'd like to suggest a small change to paper n1613 - "Proposal to add Design
by Contract to C++". I think that the ':' symbol (meaning 'otherwise') used
in precondition blocks should be exchanged for 'else' keyword. That is the
example

    in
    {
      r > 0.0: throw bad_input();
    }

should look like this:

    in
    {
      r > 0.0 else throw bad_input();
    }

I can list at least two reasons for this:
1. 'else' is much more meaningful and obvious than ':', it's easier to
understand the code,
2. 'else' is much more readable, especially in long expressions or those
containing the ?: operator.

Greetings,
RK


---
[ comp.std.c++ is moderated.  To submit articles, try just posting with ]
[ your news-reader.  If that fails, use mailto:std-c++@ncar.ucar.edu    ]
[              --- Please see the FAQ before posting. ---               ]
[ FAQ: http://www.jamesd.demon.co.uk/csc/faq.html                       ]